Benachrichtigungen
Alles löschen

Home Assistant Integration

Seite 3 / 6
eic1cr
(@eic1cr)
Eroberer

Möglich, da kenne ich mich aber zu wenig aus.

Ich habe die Image Datei von Home Assistant damals direkt auf die SD Karte für den Raspberry geflasht. Da war Supervisor da.

AntwortZitat
Veröffentlicht : 20/03/2021 11:44 am
eic1cr
(@eic1cr)
Eroberer
Veröffentlicht von: @eic1cr

Wenn du SSH installiert hast, kannst du direkt im Windows Explorer den custom_components Ordner erstellen und den freeathome Ordner darin einfügen.

Muss mich korrigieren... Habe SSH mit dem Addon Samba share verwechelt. Mit Samba share kannst du in Windows auf die Ordner von Home Assistant zugreifen:

SSH benögt man, um bspw. HACS zu installieren.

AntwortZitat
Veröffentlicht : 20/03/2021 1:57 pm
eic1cr
(@eic1cr)
Eroberer

Hi,

kurze Frage in die Runde: Funktioniert bei euch die free@home Integration in Home Assistant noch? Bei mir geht seit vorgestern nichts mehr, habe aber noch nicht herausgefunden wo das Problem liegt.

Nur damit ich weiß, ob ich etwas falsch gemacht habe, oder ob es ein generelles Problem gibt.

Habe schon einen Issue auf github erstellt.

Grüße und schöne Ostern

AntwortZitat
Veröffentlicht : 02/04/2021 2:59 pm
eic1cr
(@eic1cr)
Eroberer

Hi,

habe heute herausgefunden was bei mir der Grund ist, weshalb f@h in Home Assistant nicht mehr funktionierte.

An dem Tag, an dem das Problem zum ersten Mal auftauchte, habe ich meine ersten beiden Echo Dots in Betrieb genommen. Da ich Alexa schon länger mit f@h verknüpft habe, bisher aber nur per Alexa App auf dem Smartphone verwendet habe, konnte ich mir nicht vorstellen, dass es da einen Zusammenhang gibt.

Habe heute ohne große Hoffnung versucht Home Assistant neu zu starten, wenn die beiden Echos vom Strom getrennt sind.

Ergebnis: Alexa nicht eingesteckt, f@h funktioniert in Home Assistant; Alexa eingesteckt, f@h funktioniert nach einem Reboot nicht mehr in Home Assistant.

Da ich weder f@h in Kombination mit Home Assistant, noch Alexa in Kombination mit f@h missen möchte, bin ich jetzt einigermaßen ratlos, wie ich beides verwenden kann...

Hat jemand beides am Laufen oder kennt eine Lösung für mein Problem?

AntwortZitat
Veröffentlicht : 05/04/2021 2:20 pm
eic1cr
(@eic1cr)
Eroberer

Update:

Habe den beiden Echo Dots in meinem Router eine feste IP-Adresse und einen Namen zugewiesen. Seitdem funktioniert wieder alles 😀 

AntwortZitat
Veröffentlicht : 05/04/2021 3:25 pm
Chrysso
(@chrysso)
Foren Ass
Veröffentlicht von: @mz83

Falls Jemand noch herausfindet, wie man die Welcome Anlage integrieren kann, bitte melden. 😇 

Hallo zusammen. Ich habe nun HA auch am laufen und sieht erstmal sehr gut aus. Leider fehlt mir die Entität der Klingel vom Welcome System bereitgestellt. 

In den Logs taucht diese auch nicht auf, wenn ich die Klingel betätige. Hat das schon jemand zum Laufen gebracht?

 

LG Chrysso

AntwortZitat
Veröffentlicht : 10/04/2021 8:57 am




eic1cr
(@eic1cr)
Eroberer

@chrysso

Ich habe es folgendermaßen zum Laufen gebracht:

- zuerst einen freien Schaltaktor verwenden um eine "virtuellen Aktor" zu erstellen oder irgendetwas anderes schaltbares, das in HA integriert ist, aber ansonsten keine Verwendung hat nehmen:

- anschließend in f@h einen Türruf platzieren und eine Aktion erstellen, siehe hier:

https://www.freeathome-forum.de/community/postid/5249/

- in der Aktion plazierst du die zuvor erstellte Lampe (kann auch eine Scene / Steckdose etc. sein, Hauptsache HA bekommt eine Statusänderung der Entität mit, sobald es an der Tür klingelt):

- jetzt HA einmal neu Starten, dass die neue Entität gefunden wird

- dann kannst du die Klingel in HA zum Beispiel per Automatisierung auf Smartspeakern läuten lassen 😀 :

Eine Frage hätte ich auch noch. Läuft es bei dir mit der neuesten Version? Habe noch nicht upgedated, weil bei mir derzeit alles funktioniert:

 

 

AntwortZitat
Veröffentlicht : 10/04/2021 10:56 am
MZ83 gefällt das
Chrysso
(@chrysso)
Foren Ass

@eic1cr

 

Danke, den Workaround werd ich dann auch bei mir einsetzen. 

 

Ich habe gestern erst meinen RasPi bekommen und für mich ist das alles völliges Neuland. Also ich bin gerade dabei die ersten Programmierungen zu realisieren. Bis dato sieht es gut aus. 

 

Ich habe OS 5.13, Core ist noch bei "core-2021.4.1". 

 

Die 4.2 wurde mir heute morgen angeboten, habe ich aber noch nicht installiert. Ich muss mich jetzt erstmal mit den Grundsätzen beschäftigen. 

AntwortZitat
Veröffentlicht : 10/04/2021 12:24 pm
eic1cr gefällt das
Dark_Templar
(@dark_templar)
Eroberer

HA 2021.6 würde ich nicht installieren, wenn es rauskommt, sonst ist es vorerst vorbei.

Im Log von HA findet man diesen Hniweis:

No 'version' key in the manifest file for custom integration 'freeathome'. As of Home Assistant 2021.6, this integration will no longer be loaded. Please report this to the maintainer of 'freeathome'

AntwortZitat
Veröffentlicht : 13/04/2021 9:44 pm
eic1cr
(@eic1cr)
Eroberer

@dark_templar

danke für den Hinweis.

Habe eben mal in github geschaut ob sich da was tut.

Vor zwei Tagen hat jheling den Version key in manifest.json eingefügt. 

Daher sollte man das Problem auf zwei Möglichkeiten lösen können:

--> Entweder den aktuellsten Code downloaden und mit dem eigenen ersetzen. Ist mir aber zu umständlich und riskant, nicht dass hinterher so manches nicht mehr wie vorher läuft.

--> oder, so werde ich es testen, folgende Zeile selbst in manifest.json einfügen 

AntwortZitat
Veröffentlicht : 14/04/2021 5:36 am
Chrysso
(@chrysso)
Foren Ass
Veröffentlicht von: @mz83

So ich habe das mal installiert und mal geschaut, was so geht.

Ich habe nun folgendes in einem System zusammen gefasst:

- Free@Home (Sensoren, Aktoren, Szenen, Wetterstation)

- Phillips HUE (2 AP´s, Leuchten, Dimmer, BW-Melder!)

- Fritzbox

- Sony TV, Playstation 4

- Sonos

- Spotify

- Zehnder Lüftung

- Homekit

- Gardena

- Husquana

- Drucker von Brother

- Google Cast

- Synology

 

Hersteller: https://www.home-assistant.io/

F@H Integration: https://github.com/jheling/freeathome?fbclid=IwAR1tTSnlGBYvcLkngjKUp4mMjDea57P-C2ZB6XK3SfMW9GQQ0dVi2RXqDS4

Erste Schritte:

 

Dazu muss man sagen, dass das meißte Plug and Play ist und relativ simpel einzubinden! Ein schönes Spielzeug.

 

Darf ich - wenn auch etwas offtopic - fragen, wie Du die Zehnder Anlage installiert bekommen hast? 

Ich habe auch eine aber ich bin zu blöd das zu installieren, bzw. stehe auf dem Schlauch. 

Kannst Du mir da ne kurze Starthilfe zu geben?

 

Danke und Grüße

Chrysso

AntwortZitat
Veröffentlicht : 15/04/2021 4:24 pm
Dark_Templar
(@dark_templar)
Eroberer

Da kann ich auch etwas helfen.

Habe die Zehnder auch in HA, das ergibt mit der Fritzbox nämlich interessante Möglichkeiten.

Mit der Fritzbox tracke ich mein Handy (Daheim vs. nicht daheim) und das meiner Frau.

Sind wir beide für 30 Min nicht daheim, geht die Lüftung in Grundlüftung. Ist einer von uns daheim, geht die Lüftung auf Normal. Zwischen 22:00 und 09:00 ist die Lüftung immer auf Normal.

Darüber hinaus hat mich nicht nur die relative Luftfeuchtigkeit innen/aussen/Zuluft interessiert, sondern die absolute Luftfeuchtigkeit, die kann man mit einem individuellen Sensor selbst berechnen. Mal sehen ob ich darauf im Sommer noch Steuerungsfunktionen für die Lüftung aufsetzte.

Die Steuerung der Lüftung habe ich mittlerweile 100% an HA abgegeben.

So sieht das bei mir aus:

 

Aber zur eigentlichen Frage 🙂

a) Du musst diese Datei runterladen: https://github.com/michaelarnauts/comfoconnect/archive/refs/heads/master.zip

b) Entpacken. Darin ist ein Ordner "comfoconnect-master". Umbenennen in "comfoconnect"

c) Diesen übertragen in den HA in den Ordner "config".

Wenn du noch keinen Zugriff auf das Filesystem deines HA hast, musst du das Addon "samba share" installieren. Wenn das absolut nicht klappt, melde dich. War bei mir auch überraschend schwierig.

d) In der Configurationsdatei configuration.yaml (Addon: "Visual Studio Code" dafür installieren)

Der Anleitung hier folgen: https://www.home-assistant.io/integrations/comfoconnect/

Du musst eigentlich nur eingeben:

comfoconnect:
host: ip.ip.ip.ip
pinDeinePin (wenn nicht geändert: 0000) Wenn du die Pin nicht mehr weisst: Reset der ComfoConnect LAN
 
Zwei Leerzeichen vor host und pin.
 
Des Weitere in diese Datei einfügen:
sensor:
  - platform: comfoconnect
    resources:
      - air_flow_exhaust
      - air_flow_supply
      - bypass_state
      - current_humidity
      - current_rmot
      - current_temperature
      - days_to_replace_filter
      - exhaust_fan_duty
      - exhaust_fan_speed
      - exhaust_humidity
      - exhaust_temperature
      - outside_humidity
      - outside_temperature
      - power_total
      - power_usage
      - preheater_power_total
      - preheater_power_usage
      - supply_fan_duty
      - supply_fan_speed
      - supply_humidity
      - supply_temperature
 
e) Wenn erledigt: Einstellungen, Serversteuerung, Konfiguration überprüfen, wenn iO: Neustart von HA. Wenn niO, ist ein Fehler in der  configuration.yaml
AntwortZitat
Veröffentlicht : 15/04/2021 9:00 pm
Chrysso gefällt das




Chrysso
(@chrysso)
Foren Ass

@dark_templar

 

Absoluter Hammer! Ganz herzlichen Dank für die klasse Anleitung; tatsächlich ist der Zugriff auf das Filesystem und auch das Editieren der configuration.yaml für mich kein Thema. 

Ich bin aber daran gescheitert, die richtigen Dateien zu finden und zu laden. Hier war u.a. die Rede von Pip3 install unter Python, aber da bin ich ausgestiegen. 

 

Werde das Wochenende die Installation vornehmen und gebe Bescheid.

 

Nochmals lieben Dank für Deine Mühe!

Chrysso

AntwortZitat
Veröffentlicht : 16/04/2021 4:48 pm
Chrysso
(@chrysso)
Foren Ass

Ich hab es zum Laufen gebracht!! Super!

Jetzt noch eine Frage: Wie hast Du die Lüftersteuerung reingebracht? Ich kann alle Werte abrufen und nur die Lüftung an und aus schalten.

 

Die einzelnen Lüfterstufen finde ich aber nicht ... 

AntwortZitat
Veröffentlicht : 17/04/2021 8:27 am
Dark_Templar
(@dark_templar)
Eroberer

Das freut mich - war bei mir auch eine Zangengeburt 😉

Lüftung steuere ich über 3 Skripte:

off = nicht aus sonder "away" Modus

mow = Stufe 1

medium = stufe 2

high = stufe 3

Diese Skripte habe ich als "Elemente" Tafel in die Oberfläche hinzugefügt:

(Away habe ich nicht belegt, das dieser bei mir automatisch über den device tracker von HA, wie oben beschrieben, umgesetzt wird)

AntwortZitat
Veröffentlicht : 17/04/2021 10:51 pm
Seite 3 / 6

Teilen: