Benachrichtigungen
Alles löschen

OpenHAB @ Raspberry Pi

127 Beiträge
25 Benutzer
23 Likes
18.7 K Ansichten
Alex
 Alex
(@alex)
Beiträge: 198
Reputable Member Admin
Themenstarter
 

Ich habe mich mal mit OpenHAB auf einem Raspberry Pi auseinandergesetzt und es nach langem hin und her geschafft, die free@home Geräte "sichtbar" zu machen.

Über das integrierte HAB Panel habe ich für die einzelnen Etage angefangen "Dashboards" zu bauen von wo aus sich sämtliche Aktoren auf der Etage ansprechen lassen.

Wie sind eure Erfahrungen mit OpenHAB oder ähnlichen Lösungen?

Hier sind noch zwei Screenshots von den Dashboards.

Dieses Thema wurde geändert Vor 3 Jahren von Alex
 
Veröffentlicht : 01/09/2019 4:05 pm
MZ83, superking and Chris reacted
Schlagwörter für Thema
 Alox
(@alox)
Beiträge: 80
Estimable Member
 

Ich höre davon zum ersten Mal. Klingt aber nicht uninteressant. Ich denke mal, zukünftig werden Lösungen immer wichtiger, die verschiedene Smarthome-Systeme zusammenfassen (oder bin ich da aufm Holzweg)?

 

Hast du ein paar mehr Infos, was du damit nun machen kannst, was nicht via F@H-App geht oder was die Vorteile sind?

Diese r Beitrag wurde geändert Vor 3 Jahren von Alox
 
Veröffentlicht : 11/09/2019 9:22 pm
Alex
 Alex
(@alex)
Beiträge: 198
Reputable Member Admin
Themenstarter
 

Die OpenHAB Lösung bietet die Möglichkeit, alle gewünschten Komponenten auf einen Blick verfügbar zu haben und das ohne nennenswerte Ladezeiten, wie man sie aus der free@home App kennt.

Könnte ich mir auf einem an der Wand montierten Tablet auch gut als Alternative zum 7" Panel vorstellen.

Leider fehlt mir im Moment die Zeit mich intensiver damit zu beschäftigen. Ich habe auch schon recht lang gebraucht um das ganze überhaupt erstmal ans Laufen zu kriegen.

Wenn Interesse besteht kann das ganze bei github.com nachgelesen werden.

Ich werde das ganze bei Gelegenheit auch nochmal selbst auf deutsch beschreiben. Ich fürchte allerdings dass ich dafür das ganze nochmal neu aufsetzen muss ? 

 
Veröffentlicht : 11/09/2019 9:55 pm
Phase and MZ83 reacted
(@alexander)
Beiträge: 10
Active Member
 

@alex

Hallo Alex,

ich bin auch gerade dabei den IO broker zu integrieren.

Wirklich super was man damit alles für Systeme zusammen bringen kann.

Free @Home wäre natürlich auch super.

Kannst Du in etwa schreiben wie du vorgegangen bist?

In OpenHab habe ich leider noch keinerlei Erfahrung.

Gruss 

Alex

 
Veröffentlicht : 26/09/2019 2:56 pm
Alex
 Alex
(@alex)
Beiträge: 198
Reputable Member Admin
Themenstarter
 

Hi Alex ? 

Ich habe zuerst Raspbian und OpenHAB installiert.
Informationen zur installation von OpenHAB gibt es hier

Wenn ich mich recht erinnere, habe ich dann direkt über OpenHAB (PaperUI) das free@home Binding installiert.

Habe hier nochmal einen Link zu einer passenden Anleitung.

Die free@home Komponenten werden nach erfolgreicher Installation und Aktivierung im PaperUI angezeigt. Leider waren hier (zumindest bei mir) die Bezeichnungen etwas verwirrend. jeder Kanal wird jeweils mit der Bezeichnung des ersten Kanals angezeigt.

Hier mal ein Beispiel:

Die Unterscheidung findet lediglich im Kanal (Ch0000 bis Ch0003) statt. Dabei steht Ch0000 für Kanal "A" und Ch0003 für Kanal "D".

Hoffe die Links helfen Dir erstmal weiter. Ich habe die Installation über die Kommandozeile vorgenommen (wird jeweils auch beschrieben).

Die Erstellung der Dashboards habe ich dann im HABPANEL (auch Teil von OpenHAB) vorgenommen.

 
Veröffentlicht : 26/09/2019 10:49 pm
mastermix and MZ83 reacted
(@alexander)
Beiträge: 10
Active Member
 

@alex

Super Alex vielen Dank für Deine Ausführungen.

Dann werde ich mich Mal an die Arbeit machen.

 
Veröffentlicht : 28/09/2019 11:32 pm
(@alexander)
Beiträge: 10
Active Member
 

@alex

So habe es nach längerem hin und her nun auch geschafft. 

Muss dazu sagen bin bei weitem kein Elektroniker, Programmierer oder so etwas. (Wäre es jedoch sehr gern....bin fleißig am lesen)

Bin richtig angefixt was das Thema Smart Home angeht. 

Habe meine ersten Versuche nun mit IO Broker hinter mir und muss sagen, ja das ist echt eine super Lösung. 

Warum habe ich damit angefangen; ja eigentlich nur aus einem Grunde; ich habe neu gebaut und mich dabei, während der Bauphase, für Free@Home  entschieden. 

Ja während der Umbauphase; bedeutet ich habe sozusagen eine Hybride Elektroinstallation. 

Sprich 50% herkömmlich / 50 % Free@Home.

Ist das eine gute Lösung ... mit Nichten, war jedoch nicht anders umsetzbar. 

Ich finde die Free@Home Lösung gut und habe auch gefallen an Smart Home gefunden.

Nun wollte ich  also die anderen 50 % nachrüsten.

Das ist jedoch (meiner Meinung nach) extrem teuer.

(Wireless/Schaltaktoren etc.); da kommt gut und gerne je Schalter mal zwischen 50 und 100  EUR zusammen.

Was habe ich nun gemacht.

Habe mir Shelly´s (WLAN Relais) bestellt. (Kosten 10 EUR je Relais); hiermit kann ich unter anderem Lichter schalten

Temp. Sensoren von Xiaomi (Kosten bei einem schlechten Kurs ca. 10 EUR je Stk) 

Fensterkontakte von Xiaomi (Kosten bei einem schlechten Kurs ca. 10 EUR je Stk) 

Deren Zustand kann ich nun sehr komfortabel (auch als nicht Elektroniker/Programmierer) im IO Broker auslesen und Wenn/Dann Aktionen anlegen. (hierfür habe ich einen Raspi 4 kaufen müssen; Invest ca. 100 EUR) 

Nun war die (für mich) große Herausforderung Free@Home und den Rest meiner "Smart Home Welt" zusammenzubringen und zu interagieren.

Da bin ich auf den Beitrag von Alex gestoßen.

Erst einmal vielen Dank 🙂 

Wie gesagt die Anbindung via Openhab und IO Broker hat funktioniert. 

Was habe ich gemacht?

Ich habe einen weiteren Rasp gekauft (diesmal einen Raspi 3+)

Hier habe ich nach Anleitung im Netz Openhab installiert und dann das "Binding" freeathome installiert. 

Nach einer kurzen Suche werden (fast) alle Aktoren gefunden.

Wenn man diese dann als "Thing" aktiviert erscheinen Sie unter "Control" im "Paper UI".

Und das war es dann auch schon (ist etwas Fleißarbeit, lohnt sich aber) 

Nachdem die Aktoren in Open Hab unter "Control" im "Paper UI" angezeigt werden kann man die Zustände im IO Broker ebenfalls auslesen. (Hierfür muss man einfach im IO Broker den Adapter Openhab herunterladen und einrichten (geht easy).

Nun kann man alle Aktoren miteinander aggieren lassen.

Xiaomi/Shelly/Free@Home/Hue/Osram/DECT/ etc....

finde ich ne feine Sache. 

@Alex hast Du evtl. auch reine  Sensor/Schaltaktoren im Einsatz (z.B. Sensor Schaltaktor 6211/1.1

Diese werden leider im Binding nicht gefunden.

Kannst Du mir evtl. weiterhelfen?

@Rest: Wenn Ihr mit dem Gedanken spielt eure Free@Home Welt um andere (nicht Busch Jäger) Komponenten zu vergrößen, kann ich euch nur diese Variante empfehlen.

Ja ich weiß dass die Entwickler API freigegeben wurde, aktuell scheint es meiner Ansicht nach jedoch keine andere Nutzerfreundliche Alternative zu geben.

Hoffe ich konnte den ein oder anderen inspirieren.

Ich Wünsche allen hier einen guten Rutsch ins neue Jahr. 

Gruß 

Alexander

 

 
Veröffentlicht : 31/12/2019 1:56 pm
mastermix reacted
ropla
(@ropla)
Beiträge: 79
Trusted Member
 

@alexander

Hallo Alexander,

danke für deinen Erfahrungsbericht! Ich habe in meinem kernsanierten Altbau auch eine hybride Installation und plane einige Nachrüstungen (neben Standard-Schaltaufgaben auch einige Sonderlösungen wie Einbindung von RFID, einen Briefkasten-Füllsensor, Leckagesensoren für Wasch- und Spülmaschine, ggf. auch Gartenbewässerung usw.). Mit deinen Hinweisen kann ich jetzt mal gezielt recherchieren...

Viele Grüße und auch einen guten Rutsch!

 
Veröffentlicht : 31/12/2019 3:11 pm
mastermix and Alexander reacted
(@schuppi139)
Beiträge: 53
Trusted Member
 

@alex

 

wirklich interessant. Das klingt sehr viel versprechend. Ich habe bis jetzt auch f@h inkl sonos und hue. Ich bastel jetzt grad parallel daran die Brötje Gas Therme mit Solarthermie zu „digitalisieren“. Das wäre dann natürlich ne feine Sache wenn das dann alles im ioBroker laufen würde. Da reißen meine Projekte so schnell nicht ab. 

 
Veröffentlicht : 05/01/2020 11:08 am
(@triple5soul)
Beiträge: 5
Active Member
 

@alex 

Bei mir klappt das mit dem Binding und dem hinzufügen der Aktoren nicht. Könntest Du mir einen Link zukommenlassen wo erklärt wird wie man das ganze über die Konsole einstellt?

 
Veröffentlicht : 05/01/2020 3:34 pm
(@alexander)
Beiträge: 10
Active Member
 

@triple5soul

ich denke Alexander hat mit dem Umzug des Forums momentan reichlich zu tun, daher versuche ich mal auszuhelfen. 

Also ich gehe mal davon aus, dass OPENHAB bereits läuft!?

Was ist nun zu tun.

Die Installation des Bindings wird hier gut beschrieben.

Binding Free@Home unter OPENHAB

Wenn Ihr das so ausgeführt habt, müssten alle Aktoren unter 

Configuration/Things ersichtlich sein.

Nun könnt Ihr Sie allerdings noch nicht ansteuern.

Dafür müsst Ihr Sie auf die Ebene "Control" bekommen.

Hierfür geht Ihr unter Configuration/Things und wählt den gewünschten Aktor aus: 

Ich mache das mal beispielhaft an einem Jalousieaktor: 

Hierzu müsst Ihr auf das Edit Symbol (Stift)

Namen festlegen (in meinem Fall "Jalousieaktor Test)  

Namen Festlegen und über das Haken Symbol bestätigen.

Im Anschluss muss der einzelne Kanal ausgewählt werden und ein "ITEM" erstellt werden.

Im Fall von Jalousieaktor gibt es 3 Kanäle die man ansteuern kann 

Stepwise (Stufenweise rauf/runterfahren)

Complete (Komplett rauf/runterfahren)

Percentege (Prozentual rauf/runterfahren)

Wir erstellen eine ITEM für Kanal Complete:

Einstellung: 

System Default

+ Create new ITEM 

Im Anschluss auf Link klicken.

Unter dem Menüpunkt Control müsste nun der Aktor/Kanal ersichtlich sein.

Hier könnt Ihr über die Symbole nun den Aktor steuern.

Ich hoffe ich konnte etwas Licht ins Dunkle bringen.

Grüße 

Alex

 
Veröffentlicht : 06/01/2020 1:15 pm
(@triple5soul)
Beiträge: 5
Active Member
 

@alexander

Hallo Alexander, 

Danke für Deine Anleitung.

ja Openhab läuft (zwar auf Windows, sollte aber kein Problem sein)

Das Binding welches Du verlinkt hast ist nicht das aktuelle und funktioniert nicht mit Openhab 2.5.

Ich habe dann das Bindung aus dem Openhab Forum genommen. Der SysAP geht bei mir auch online, nur werden keine Aktoren gefunden. Wenn ich dann manuell einen Aktor über seine ID ABBxxxxxxxxxxx anlege, geht der auch online, nur wenn ich dann ein Item verknüpfe passtiert nichts. 

 
Veröffentlicht : 06/01/2020 6:00 pm
(@happydexter)
Beiträge: 13
Active Member
 

@triple5soul

Ich bin gerade auch dran das einzurichten und auszuporbieren. Habe auch zu Testzweckne erstmal die Windows Variante gewählt. Ich hatte zunächst das Binding aus dem Market genommen, da habe ich aber die f@h Bridge nie Online bekommen. nach Googlen habe ich dann auch die Version aus dem openHAB Forum genommen und mit einigen Install und Uninstall versuchen hat es bei mir dann geklappt die Bridge Online zu bekommen. Bei mir wurden dann allerdings auch die "meisten" Aktoren gefunden und ich kann sie nutzen. Heute wollte ich  die Bewegungsmelder probieren, da ist mir aufgefallen, dass diese scheinbar nicht gefunden wurden. Jetzt habe ich das gleiche Verhalten wie Du auch, ich kann sie manuell anlegen, sie gehen auch Online, aber wenn ich versuche sie zu benutzen passiert nichts!

 
Veröffentlicht : 09/01/2020 1:02 pm
(@triple5soul)
Beiträge: 5
Active Member
 

@happydexter

Hallo happydexter,

habe den Fehler bei mir gefunden. Es lag daran, dass ich nicht das "Installer" Benutzerkonto genommen habe, sondern einen neuen Benutzer mit Installer Rolle.

Danach wurden alle Geräte (Bewegungsmelder habe ich nicht) bis auf meinen Wireless 2/2 Sensor/Aktor gefunden. Den Wireless Sensor/Aktor habe ich dann mit dem neuen Busmonitor im Free@Home ausgelesen, da hier die channel nicht automatisch von 0 starten. (Bei mir war es für die Ausgänge der Aktoren CH007 und CH008)

 

Vielleicht klappt das bei Dir ja auch.

-Busmonitor starten

-Autoscroll aktivieren

- Bewegungsmelder auslösen

- ID und Channel notieren

- neunes Thing anlegen mit den oben notierten Daten.

 

Gruß Triple5Soul

 
Veröffentlicht : 09/01/2020 6:53 pm
(@alexander)
Beiträge: 10
Active Member
 

@triple5soul

kurze Frage:

Ich habe auch das Problem, dass mein Sensor/Schaltaktor nicht gefunden wird.

Würde daher auch gerne Deinen Vorschlag ausprobieren mit dem Busmonitor.

Allerdings kann ich diesen in Free@Home nicht finden.

Könntest Du bitte etwas näher darauf eingehen, wie ich den Busmonitor finde/starte etc.

Vielen Dank schon einmal

 
Veröffentlicht : 09/01/2020 9:09 pm
Seite 1 / 9
Teilen: